Ankündigung

Einklappen
Keine Ankündigung bisher.

Cuda ohne Internet erfolgreich installieren

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Cuda ohne Internet erfolgreich installieren

    Ich hab' mir vom letzten Geld eine GT730 gekauft und ganz naiv gedacht, ich bekäme Cuda auf Ubuntu 14 zum Laufen. Wobei Blender gar nicht mal der ausschlaggebende Faktor war, sondern eher Meshroom.

    Natürlich läuft Cuda nicht. Ich hab' mir die 1.7Gb große Datei heruntergeladen und sie ist auch installiert, aber natürlich bleibt Meshroom schwarz und Cycles beharrt auf 'None'. Immerhin sind im Vergleich zur gt210 schon mal wesentlich mehr Verts pro Sekunde drin.

    Großes Problem: Ich habe 64kbit Versagerinternet, insofern sind die meisten Tutorials zum Scheitern verurteilt. Nicht mal ein sudo apt-get update ist drin, ohne keine Ahnung wie lange zu warten (Es sagt ja nicht, wann es fertig wird).

    Weiß jemand, wie man das Problem diagnostiziert und es behebt? Sachen runterladen kann ich in der Uni, nur direkt am Rechner tröpfeln die bits.

  • #2
    Ähnlichen Ärger hatte ich auch schon. Ich kann mich aber nicht mehr erinnern, wie ich das gelöst habe. Das hast du sicherlich beachtet: https://wiki.ubuntuusers.de/Nvidia_CUDA_installieren/

    Hast du die Nvidia-Driver und Nvidia-Settings installiert? https://www.nvidia.de/download/drive....aspx/81351/de
    Aktuell: W E I H N A C H T S W I C H T E L N Mein Blog: Downtown Blendpolis.

    Kommentar


    • #3
      Von den Nvidia-Treibern habe ich die Version 340.76 installiert. Ich habe zwar auch die neueste Version da (410.73), hab' das Installieren aber nicht hinbekommen und auch irgendwie Schiß davor, daß es mir vielleicht das System zerschießen könnte und ich dann ganz ohne Gebrauchsrechner dastehe.

      Ein zusätzliches Problem kann darstellen, daß meine Festplattenpartitionen nicht automatisch gemounted werden.

      Denn das angebotene "sudo apt-get install nvidia-cuda-dev" möchte 88mb runterladen. Für Menschen mit einem Leben ein Witz, für mich eine Wartezeit von ca. 5 Stunden. Cuda-toolkit sind 300mb, das wäre dann noch ein paar Minuten länger.

      Ich hatte ganz naiv gedacht, "cuda-repo-ubuntu1404-10-0-local-10.0.130-410.48_1.0-1_amd64.deb" brächte mir den Erfolg, nachdem ich erst ganz naiv gedacht hatte, der neueste Nvidia-Treiber brächte mir den Erfolg. Ich werde langsam alt und Linux wird ohne Studium oder aktuellen Internetanschluß ein wenig mühsam.

      Immerhin, alte Karte ausbauen, neue Karte einbauen, alles, was vorher lief, läuft noch immer, nur der Viewport scheint wesentlich schneller. Immerhin etwas.
      Zuletzt geändert von Haunt_House; 09.11.2018, 01:29.

      Kommentar


      • #4
        Zitat von Haunt_House Beitrag anzeigen
        nvidia-cuda-dev
        Ist glaube ich wichtig. Was hast du denn so für ein Up- Downstream? Hört sich fast nach 56k Modem an. 88mb habe ich mit 50Mbit in 90 Sekunden herunter geladen. Läuft Blendpolis wenigstens anständig?

        Wenn du den Treiber drauf hast, kannst du ja mal versuchen, Blender neu zu installieren. Vielleicht bringt das was. Irgendwann klappte es bei mir auch, wo ich nicht genau wusste, was es dann am Ende war.
        Aktuell: W E I H N A C H T S W I C H T E L N Mein Blog: Downtown Blendpolis.

        Kommentar


        • #5
          Naja, 64kbit ist 64kbit. 5 Euro Versagerinternet mit Drossel. Daß es mit 90Mbit schneller geht, das glaube ich zweifellos. Mit etwas Geduld funktioniert das Internet. Blendpolis auch. Blender betreibe ich normalerweise uninstalliert.

          Und Meshroom verbalisiert seine Probleme, wenn ich es über's Terminal starte:
          Klicke auf die Grafik für eine vergrößerte Ansicht  Name: meshroom.png Ansichten: 2 Größe: 92,1 KB ID: 20365
          Zuletzt geändert von Haunt_House; 09.11.2018, 10:30.

          Kommentar


          • #6
            Wenn Blender die CUDA-Karte akzeptiert, wird wohl auch Meshroom sie nutzen können. Da das nicht der Fall ist, steht also mehr das System hier im Fokus. Cuda ist installiert, funktionierende Treiber auch. Fragt sich, ob das System die Karte auch als Cuda-Karte erkennt und ob der Treiber auch verwendet wird.

            Was sagt
            Code:
            glxinfo|egrep "OpenGL vendor|OpenGL renderer*"

            BTW: Thema ist verschoben, weil es sich nicht um eine Blender-Technik-Frage handelt.
            Aktuell: W E I H N A C H T S W I C H T E L N Mein Blog: Downtown Blendpolis.

            Kommentar

            Lädt...
            X