Ankündigung

Einklappen
Keine Ankündigung bisher.

Geländer Texturen baken

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Geländer Texturen baken

    Hallo zusammen!

    Hier möchte ich dieses Geländer, welches aus drei Materialien besteht, zu einem zusammen fassen. Klicke auf die Grafik für eine vergrößerte Ansicht

Name: handrail.jpg
Ansichten: 1
Größe: 154,6 KB
ID: 17188
    Dabei habe ich ein neues Objekt erstellt (OttoWagner_baked) und die UV's neu sortiert.

    Mit Baken bin ich nicht weiter gekommen. Da kommen nur Fehler. Jedoch baken möchte ich auch gar nicht. Eigentlich sollen die Texturen nur zu einer zusammengefasst werden.

    Danke

  • #2
    Mittlerweile habe ich folgenden Link gefunden.
    leider klappt es noch immer nicht. außerdem glaube ich nicht, dass das für Cycles ist?
    After applying to a small studio and making a model of an axe with two pieces which meant separate UV maps. After submitting the model and textures, I was told that both the blade and handle of the...

    Kommentar


    • #3
      Ich gehe jetzt davon aus, dass Du normale Texturen, die kachelbar/tilelable sind benutzt hast, alles bereits uv-unwrapped ist und keine 3D-gepainteten Texturen dabei sind.
      Joine einmal alle Deine Teile (alles Auswählen und STRG+J)
      Dann gehst Du in den Edit-Mode wählst alles aus (A) und verteilst Deine bereits erstellten UV-Teile schön raumausnutzend im UV-Editor.
      Lege eine neue Textur an, gib ihr einen vernünftigen Namen, abhängig von der Art der Textur.
      In jedem Cycles Material Deines Objekts sollte nun eine einzelne Image-Textur-Node drin sein mit dieser Textur und auf generated gestellt. Falls das nicht so ist, musst Du die händisch erstellen und sie muss aktiv sein.
      Dann gehst Du in den Renderbereich Baken, suchst Dir das aus was Du baken willst (z.B diffuse hier nur Color auswählen, nicht direct und indirect ) und stellst noch margin ein oder lässt es auf 16 px und drückst auf baken. Speichern nicht vergessen, wenn es fertig ist.
      Das Spiel wiederholst Du mit Normal und mit Glossy.
      Ich hoffe das hilft Dir etwas weiter.

      LG
      Kushanku
      Zuletzt geändert von Kushanku; 02.07.2018, 21:41.

      Kommentar


      • #4
        Kushanku Danke für deine Zusammenfassung!
        Leider habe ich es nicht geschafft.

        Die Texturen habe ich alle in Substance Painter erstellt.
        Die UV's kann ich nicht einfach so neu erstellen, ohne die Texturen zu zerstören. Deswegen hab ich eine neue UV Map angelegt. Und genau ab da liegt mein Problem.
        Beim Baken nimmt Blender die falsche UV Map.
        Die einzelne Image-Texture-Node ist auf generated gestellt. Allerdings nach dem Abspeichern und wieder Öffnen, stellt es sich um.

        Hier ein Link zum File:
        https://1drv.ms/u/s!AiEa0T5zQ1JYnC90Oicjt2NPEO5q

        Meist probiere ich die normal-texture zu baken. da seh ich gleich, ob es geklappt hat oder nicht.

        LG
        Larry

        Kommentar


        • #5
          Zitat von Larry Beitrag anzeigen
          Kushanku
          Die Texturen habe ich alle in Substance Painter erstellt.
          Dann kann es natürlich nicht klappen, da die Texturen ja schon auf die Map gebacken sind.

          Wenn Du Deine neue UV-Map anlegst solltest Du ihr einen anderen Namen geben oder ne Ziffer hinten dranhängen.
          Also die Teile zusammenfassen wie gehabt.
          Unter Object Data > UV Maps steht dann ja wohl UVMap.
          Hier auf das +Zeichen klicken = neue UV Map mit .001 hinten dran.
          Diese auswählen und neu unwrappen.
          Jetzt hat das Teil schonmal zwei UV-Maps.
          Die neue ausgewählt lassen und dann das Prozedere mit neue Textur erstellen, benennen, einzelne Image Texture-Node im jedem Mat anlegen, die neu angelegte Textur dort laden (Pulldown-Menue verwenden), dann geht die Node automatisch auf generated, aussuchen was gebacken werden soll (Diffuse.....oder, oder ..... usw.) und baken.

          LG
          Kushanku
          PS.: Habe es jetzt auch mit Deiner Datei probiert. Klappt vorzüglich, wenn die neue UV-Map ausgewählt ist.
          Noch ein kleiner Tipp. Beim Rendern mit den neuen Texturen solltest Du darauf achten, dass die neue UV-Map aktiv ist (Kamerasymbol aktivieren).
          Zuletzt geändert von Kushanku; 03.07.2018, 18:10.

          Kommentar


          • #6
            Hallo!

            Also wenn ich die neue UVMap auswähle, so zerstört es sofort die normal map. Das sehe ich im Vierport. Aber nur so kann ich die neue Map auch baken. Deswegen habe ich mir folgendes überlegt: Klicke auf die Grafik für eine vergrößerte Ansicht

Name: handrail_2.jpg
Ansichten: 1
Größe: 189,9 KB
ID: 17273 so sieht das Objekt noch in Ordnung aus und ich kann es mit der neuen UVMap baken. Nur sehen alle Farben in der normalen texutre gleich aus. Also einheitlich. Klicke auf die Grafik für eine vergrößerte Ansicht

Name: handrail_3.jpg
Ansichten: 1
Größe: 97,2 KB
ID: 17274
            Egal wohin ich das Kamerasymbol in der UVMap aktivere, es hat mir noch nie das richtige Ergebnis gebracht.

            LG
            Larry

            Kommentar


            • #7
              gerade eben habe ich die neueste build von blender ausprobiert und die normal map wurde richtig dargestellt.
              ich kann es noch nicht glauben...

              Aus der Auswahl zum Baken, welche von denen ist die Metallic?
              Zuletzt geändert von Larry; 04.07.2018, 17:25.

              Kommentar


              • #8
                Zitat von Larry Beitrag anzeigen
                Egal wohin ich das Kamerasymbol in der UVMap aktivere, es hat mir noch nie das richtige Ergebnis gebracht.
                Das Kamerasymbol der neuen UV-Map muss nur beim späteren Rendern aktiviert sein, wenn das Material mit den neu gebackenen Texturen benutzt wird. Beim Baken der Textur selber muss sie nur ausgewählt sein. Also sichtbar im UV-Editor.
                Zitat von Larry Beitrag anzeigen
                Aus der Auswahl zum Baken, welche von denen ist die Metallic?
                Puuh schwere Frage.
                Ich würde erst mal die Diffuse in den Color Kanal stecken und dann Metallic voll aufdrehen und gucken was da rüber kommt. Dann zum Vergleich die Glossy Color (auch wieder nur Color baken ohne direct und indirect, das dauert sonst ewig) in den Metallic Kanal stöpseln. Mit einer Math-Node (multiply) zwischen der Glossy Color-Textur und dem Metallic Eingang der PrincipledBSDF-Node kannst Du die Stärke steuern.

                LG
                Kushanku

                Kommentar


                • #9
                  Kushanku Danke für deine Unterstützung. Sonst hätte ich es niemals zusammengebracht!

                  Kommentar


                  • #10
                    Hallo nochmals!

                    Jetzt versuche ich es mit drei UV's zu baken. Aber schon beim Joinen der einzelnen Objekte verliere ich Texturen. Klicke auf die Grafik für eine vergrößerte Ansicht

Name: handrail_4.jpg
Ansichten: 1
Größe: 159,2 KB
ID: 17478
                    hier ein Link zur blend Datei: https://1drv.ms/u/s!AiEa0T5zQ1JYnDBiWDLy3e75WxWi


                    Mein Ziel ist es lediglich eine 4k Normal Map auf die UVMap.002 zu baken.

                    Egal was ich auch versuche, die verloren gegangenen Materialien kann ich nicht reparieren.

                    Danke

                    Kommentar


                    • #11
                      Mmmh, ich weiß ja nicht wo Dein Denkfehler liegt. Man muss fürchterlich aufpassen, das man mit den UV-Maps nicht durcheinanderkommt beim Anlegen.
                      Ich habe jetzt drei seperate Objekte angelegt, jedes UV-unwrapped (auf die Namensgebung geachtet) und eine procedurale Textur (je eine andere) als Bump-Map zugewiesen. Dann habe ich diese drei Objekte vereint (STRG+J). Eine neue UV-Map angelegt mit entsprechender Benennung. Hier darauf geachtet, dass diese dann auch markiert war, als die drei Teile neu unwrapped wurden.
                      Die Map ist ja immer noch markiert dann. Die seperate aktive Texture-Node in den drei Materialien angelegt. Im UV-Editor eine neue Textur angelegt und in diese separate Textur-Node über Pulldown-Menue geladen, falls nicht schon passiert.
                      Ja und dann habe ich auf bake gedrückt nachdem ich Normal aus dem AuswahlMenue gewählt hatte.

                      Klicke auf die Grafik für eine vergrößerte Ansicht  Name: 3 UV-Maps-to1 UV-Map.jpg Ansichten: 1 Größe: 118,7 KB ID: 17484
                      Das funktioniert auch, wenn die drei Objekte bereits gebackene Texturen haben. Habe testhalber dem Solo-Würfel die Voronoi-Textur draufgebacken und im Material entsprechend zugewiesen.

                      LG
                      Kushanku

                      PS.: Ich habe jetzt Deine Datei angeguckt. Bei dem einem Material ist gar keine Normal-Map dabei, dieses glänzende grüne Material für das Rad und die 4 Stangen rundherum. Die sind glatt wie ein Kinderpopo.
                      Zuletzt geändert von Kushanku; 12.07.2018, 21:42.

                      Kommentar


                      • #12
                        Leider weiß ich auch nicht, wo mein Denkfehler liegt?

                        Zumindest kann ich einen Teilerfolg verzeichnen. Das Vereinen (STRG+J) hat geklappt. Die UV Map heißt jetzt überall gleich und so konnte ich es ohne Verlust der Texturen vereinen. Danach wurde eine neue UVMap.001 angelegt und diese neu sortiert.
                        Mit dem Baken klappt es noch immer nicht. Entweder kommt die falsche normal UVMap raus oder sie ist bunt.

                        Hier das neue File: https://1drv.ms/u/s!AiEa0T5zQ1JYnDNkgjE--cF0_ZrZ

                        Wenn ich die UVMap.001 auswähle, so sieht es sofort fehlerhaft aus.
                        In Blender 2.8 kommt das selbe Ergebnis. Also ist es ein Anwenderfehler

                        Danke
                        und
                        LG Larry

                        PS: keine Ahnung, warum die normal map nicht angezeigt wird? ich hoffe, dass es jetzt klappt!!

                        Kommentar


                        • #13
                          Ich hätte gerne die drei Teile noch nicht gejoint. Sonst komme ich da nicht klar. Es müssen drei UV-Maps vorhanden sein.
                          LG Kushanku

                          Kommentar


                          • #14
                            bitteschön: https://1drv.ms/u/s!AiEa0T5zQ1JYnDaos0sZ6iSxUPfF

                            Kommentar


                            • #15
                              irgendwie habe ich es hinbekommen, die normal map zu baken

                              letztlich ging es dann genau so, wie du es beschrieben hast. Bei einem Material habe ich die texturen neu hinein geladen. erst dann hat es funktioniert.

                              Danke für deine Unterstützung!

                              Kommentar

                              Lädt...
                              X