Ankündigung

Einklappen
Keine Ankündigung bisher.

Bumpmap auf importiertem STL Model nicht wirksam

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge
  • Wolfram
    Empty
    • 09.07.2019
    • 4

    Ungelöst Bumpmap auf importiertem STL Model nicht wirksam

    Hallo,
    ich bin noch relativ neu bei Blender. Seit ein ca. zwei Monaten baue ich mein Wissen mit Tutorials so langsam auf.
    Ich habe auf Blenderguru ein Tutorial für die Nutzung von Bumpmaps gesehen. Funktioniert prima. Sieht man am grünen Würfel im angehängten File. Das rote Objekt ist als STL importiert. Hier wirkt die Bumpmap nicht.

    Jetzt zu den Fragen:

    * Warum funktioniert das nicht auf einem imprtierten STL Modell? Ich würde es gerne verstehen.
    * Kann man das importierte STL "heilen" so das sich eine Bumpmap darauf anwenden lässt? Wenn ja wie?
    * Wenn das STL nicht "heilbar" ist wie tausche ich am besten Daten zwischen SolidEdge und Blender aus? Es gibt leider keine Schnittmenge zwischen SolidEdge-Export und Blender-Import.

    Ich nutze eine wenige Tage alte Blender-2.8 Beta Version.

    Danke für jeden Tip oder jede Antwort.

    Wolfram
    Angehängte Dateien
  • Kushanku
    Plane
    • 31.08.2017
    • 305

    #2
    Du hast vergessen die Textur mit in das Blendfile zu packen. Dazu musst Du den Haken setzen bei File > External Data >Automatically Pack into Blend.

    Der Unterschied zwischen den beiden Objekten ist auf alle Fälle schon mal die vorhandene UV-Map beim Blender Standard-Cube. Dein STL-Objekt hat keine UV-Map. Das könntest Du aber nachholen. Bevor Du das machst musst aber Scale applyen. STRG + A > Scale. Du hast das STL-Objekt im Object-Modus skaliert.

    Kommentar

    • Wolfram
      Empty
      • 09.07.2019
      • 4

      #3
      Hallo,
      hier das Update mit Textur.

      Ok, ich werde mich an die UV-Map machen. Warum ist das Scaling im Object-Modus notwendig?

      Danke

      Wolfram
      Angehängte Dateien

      Kommentar

      • Wolfram
        Empty
        • 09.07.2019
        • 4

        #4
        Zitat von Kushanku Beitrag anzeigen
        Du hast vergessen die Textur mit in das Blendfile zu packen. Dazu musst Du den Haken setzen bei File > External Data >Automatically Pack into Blend.

        Der Unterschied zwischen den beiden Objekten ist auf alle Fälle schon mal die vorhandene UV-Map beim Blender Standard-Cube. Dein STL-Objekt hat keine UV-Map. Das könntest Du aber nachholen. Bevor Du das machst musst aber Scale applyen. STRG + A > Scale. Du hast das STL-Objekt im Object-Modus skaliert.
        Danke für den Tip. Das erstellen der UV-Map hat geholfen. Mit der Skalierung im Edit-Mode komme ich noch nicht zurecht.
        Wenn ich es auf die passende Größe skaliert habe und wieder in den Objet-Mode gehe. Verhält sich das Objekt bei der Saklierung eigenartig. Teilweise verschwindet es auch.

        Kommentar

        • Kushanku
          Plane
          • 31.08.2017
          • 305

          #5
          Zitat von Wolfram Beitrag anzeigen

          Warum ist das Scaling im Object-Modus notwendig?
          Du sollst nicht im Objekt-Modus skalieren oder rotieren und wenn Du es doch tust, musst Du es mit dem Shortcut Strg+A applyen, Blender braucht im Object-modus bei Scale die Werte 1 1 1 und bei Rotate in alle 3 Richtungen 0°. Viele Modifier und auch die UV-map machen Probleme, wenn diese Werte im Objekt-Modus verändert wurden. Skaliert oder rotiert man im Edit-Modus, werden die Werte im Objekt-Modus nicht verändert.

          Ich schaue mir Deine Datei heute Abend an. Bin grad nur am Tablet und mache Dir dann auch einen Screenshot, wo Du sehen kannst, wo Du diese Werte überprüfen kannst.
          Das Verschwinden des Objektes könnte am camera-clibbing liegen. Es gibt zwei Einstellungen. Einmal für den 3D-View und einmal für die Render-Kamera. Auch dafür ein Screenshot heut Abend.
          Zuletzt geändert von Kushanku; 13.07.2019, 09:37.

          Kommentar

          • Kushanku
            Plane
            • 31.08.2017
            • 305

            #6
            Nachfolgend einige Screeshots zum Thema Camera-Clipping und "wo sehe ich ob ich im Objekt-Modus skaliert und/oder rotiert habe".
            Die Werte unter Dimensions entsprechen der tatsächlichen Größe des jeweilig ausgewählten Objektes.
            Klicke auf die Grafik für eine vergrößerte Ansicht  Name: ApplyScale+Rotate.jpg Ansichten: 0 Größe: 159,5 KB ID: 27237
            Camera-Clipping +Ansicht mit Perspektive und ohne
            Klicke auf die Grafik für eine vergrößerte Ansicht  Name: Clipping.jpg Ansichten: 0 Größe: 96,5 KB ID: 27236
            Nachfolgend siehst Du, wie sich die UV-Map des Cubes verhält, wenn die Texture nicht quadratisch ist. Ist hier jetzt besonders schlimm, weil es kleines unruhiges Muster ist.
            Klicke auf die Grafik für eine vergrößerte Ansicht  Name: Nicht-Power-of-2.jpg Ansichten: 0 Größe: 129,7 KB ID: 27235
            Keine Ahnung, ob Dir das nun weiterhilft.
            Zuletzt geändert von Kushanku; 13.07.2019, 19:29.

            Kommentar

            Lädt...
            X